Incorrect Password Reset Links
Incident Report for Moxion
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 20:04 UTC
Identified
We've resolved the issue with our password reset emails and they are now working correctly once more.
Posted Aug 03, 2020 - 17:40 UTC
This incident affected: Moxion (Administration).