Website Down
Incident Report for Moxion
Resolved
This incident has been resolved.
Posted Oct 13, 2019 - 07:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2019 - 07:19 UTC
Identified
The Moxion website (www.moxion.io) is currently unavailable, a fix is being implemented.

In the meantime, if you need to use Moxion, please go directly to https://app.moxion.io to login.
Posted Oct 13, 2019 - 07:17 UTC
This incident affected: Website.