Moxion Desktop App for Mac Video Playback Issue
Incident Report for Moxion
Resolved
This incident has been resolved.
Posted Sep 18, 2019 - 04:28 UTC
Monitoring
A fix has been released with version 3.0.4 of the Moxion Desktop App.

The app will automatically update to 3.0.4, but quickest way to ensure you are on the latest version is to download and install it here: https://www.moxion.io/downloads
Posted Sep 18, 2019 - 03:54 UTC
Identified
We have identified an issue with video playback on the Moxion Desktop App for Mac and are working on a fix.

If you need to review video on Moxion please try another platform while we fix this issue.

For the list of platforms supported by Moxion see here: https://www.moxion.io/downloads.
Posted Sep 18, 2019 - 01:54 UTC