Slow response times
Incident Report for Moxion
Resolved
Service has been restored to normal
Posted Aug 24, 2019 - 07:47 UTC
Investigating
We are currently investigating an issue which is resulting in slow response times.
Posted Aug 24, 2019 - 07:25 UTC
This incident affected: Flow Capture (Application, Integrations/APIs).