Upload Unhide Batch Functionality Temporarily Unavailable
Incident Report for Moxion
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 20, 2019 - 08:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Feb 20, 2019 - 08:14 UTC
Identified
We have identified an issue where the Unhide Batch feature is missing from the Moxion user interface. A fix is currently being implemented.
Posted 5 months ago. Feb 20, 2019 - 07:47 UTC
This incident affected: Moxion (Uploads).